new radiator and new smoke from a 1965 Buick Skylark 300 4.9L

maseusmc

Member
Hey guys is me again. I'm once again seeking your knowledge. I recently installed a new radiator, hoses, and thermostat. I did have a bit of trouble with fitting the new radiator in the car but I managed to fit it in the car. Once I start the car sounds powerful. I had the engine completely built so I'm praying that is not my engine. This is what's going on. Smoke is coming from the lower back area of my engine. No air is coming from the air vents when I have the heater on. I can hear the blower going. Plus when then engine on, the fan creates a ton of air flow. I'm not sure if the air flow is common but its a lot of air I was told that I should be able to turn the fan with my hands but I cant.

Please help me out.
 
IF
you have a clutch fan
THEN
you should be able to spin the fan by hand when the engine is cold ... and turned off, of course.

if the fan has no clutch then this will not be true, the fan will be locked to crank by the v-belt.

if you have a clutch and it has failed, it's the better of the failure modes. the most common failure is for the clutch to stop engaging which means you overheat.



I had the engine completely built so I'm praying that is not my engine. This is what's going on. Smoke is coming from the lower back area of my engine.



it's possible some leftover oil is burning off. it may not be a problem it all, it may just quit.

keep an eye on it.

pressures and temps are all good? no spots on the floor?

it could also be excess crankcase pressure.



No air is coming from the air vents when I have the heater on.


your blower fan isn't running. this has nothing to do with the engine and is likely either a switch or fan motor problem. could also be in the dash wiring.

if you can't get hot air out of the vents, but it is blowing, then you've got a plumbing or heater core problem.
 

maseusmc

Member
so this is the update on my car and thanks for help me. I'm now getting heat its pretty warm after about 10mins. My GEN light on my dashboard stays on all the time. That doesn't seem normal. My temp light doesn't come on at all guess that is a good sign. I changed out the breather cap and I noticed zero fluid in that area but it did look moist.

I left the engine running for about 10 or so before I got tired of watching it smoke. the smoke is only coming from the lower left part of the engine.
 
Top